1

I'm getting connection refused when I try to connect to a public testnet node.

lncli --network=testnet connect 022ff54505fe9b50ce6c3c99c645c9aab67fe91abb01504c5211045b82a09aa757@103.102.44.207:9735

Error

[lncli] rpc error: code = Unknown desc = dial tcp 103.102.44.207:9735: connect: connection refused
1

You need to connect to a node which has:

  • RPC enabled
  • username and password are known
  • client IPs are whitelisted using rpcallowip
  • the router has its port forwarding enabled.

Usually, public nodes don't share their RPC parameters, because that'd be very insecure. My advice is, run your own node. Otherwise, you could use the experimental neutrino client.

  • 1
    I forgot to update my question with the answer, turns out the public node I tried to connect to was down, and the 2nd node I spun up was still syncing and therefor wasn't up. I tried more than a few on the list until I found one that worked. I'll mark yours as correct as those are valid steps. – arshbot Sep 24 '18 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.