I'm trying to run bitcoind on a Raspberry Pi 3 but I'm stuck on an error. The raspberry has a Hdd for storage with a fully indexed blockchain that was synced on my laptop and than copied to the Hdd (txindex=1).

When calling the log file I get this message:

enter image description here

Side note: I also did a reindex-chainstate=1 afterwords, but I still got this issue.

  • why does it say transaction index disabled? are you using -txindex on the pi?
    – JBaczuk
    Oct 10, 2018 at 18:46
  • I have no idea. Yes, it runs with txindex=1
    – Jeans5
    Oct 10, 2018 at 19:26
  • which version of bitcoind is the pi running?
    – JBaczuk
    Oct 10, 2018 at 19:56
  • Version 0.16.3. I followed these steps for LND ==> github.com/Stadicus/guides/blob/master/raspibolt/…
    – Jeans5
    Oct 10, 2018 at 20:01

1 Answer 1


transaction index disabled is logged when the txindex=1 or -txindex flag is not set. If it was once indexed, and you don't pass that flag, then bitcoind will prevent you from accidentally rebuilding the database without the indexes unless you explicitly tell it to with -reindex. Check your bitcoin.conf file and the startup script. Alternatively, try adding -txindex to /etc/systemd/system/bitcoind.service where bitcoind is called:

ExecStart=/usr/local/bin/bitcoind -txindex -daemon -conf=/home/bitcoin/.bitcoin/bitcoin.conf -pid=/home/bitcoin/.bitcoin/bitcoind.pid

  • Thanks, unfortunately it didn't solved it. When calling this command I get: Bitcoin server starting. But when calling the debug file, it still gives "LoadBlockIndexDB: transaction index disabled". Could it be something with RPC connections because this also doesn't work when calling for `bitcoin-cli' commands
    – Jeans5
    Oct 11, 2018 at 7:43
  • I don't think it is running at all anymore (it says Exiting), you can check with ps | aux grep bitcoind, so RPC commands won't work either.
    – JBaczuk
    Oct 11, 2018 at 14:27
  • Thanks, this gives me "admin 7651 0.0 0.0 4372 568 pts/0 S+ 16:32 0:00 grep --color=auto bitcoind". When asking for the command systemctl status bitcoind.service, I get a green message Active (running). So I assume it's running?
    – Jeans5
    Oct 11, 2018 at 14:34
  • Did you try restarting the service? sudo systemctl restart bitcoind.service? You can try running it directly (not as a service) until you get it working. bitcoind -txindex -daemon
    – JBaczuk
    Oct 11, 2018 at 14:37
  • Also this gives me the same error as above. I can't get my head around, because the same blockchain (same bitcoin folder with index and chainstate) works perfectly on my laptop with the UI. Do you think, it has something to do with the RPC credentials?
    – Jeans5
    Oct 11, 2018 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.