0

I run lnd and bitcoind under their own users, but on the same physical machine. This means lnd has trouble accessing the bitcoind .cookie, so I'm trying to configure lnd to use RPC.

When I use the following options in my lnd.conf as described in the lnd documentation:

bitcoind.rpchost=127.0.0.1:8332
bitcoind.rpcuser=joeblow
bitcoind.rpcpass=superSecretPasswordByRPAUTH.py
bitcoind.zmqpubrawblock=127.0.0.1:28332
bitcoind.zmqpubrawtx=127.0.0.1:28333

lnd errors out with the following error:

lnd.conf:16: unknown option: bitcoind.rpchost

lnd runs fine if I specify the above options using the command line like this:

lnd -bitcoind.rpchost=127.0.0.1:8332 -bitcoind.rpcuser=joeblow ... etc

This means typing in the RPC password in the command-line and command-line options can be seen by users running 'top' or task manager. This exposes RPC password to users other than 'lnd.' Having RPC password in lnd.conf is moderately more secure because the file can be locked down with chmod.

1

Found out that any bitcoind.XXX options need to be under a [Bitcoind] heading. Working lnd.conf is as follows:

[Application Options]
debuglevel=info
debughtlc=false
maxpendingchannels=5
alias=WittyAlias
color=#000300
maxlogfiles=3

[Bitcoin]
bitcoin.active=1
bitcoin.node=bitcoind
bitcoin.mainnet=1

[autopilot]
autopilot.active=1
autopilot.maxchannels=16
autopilot.allocation=0.1

[Bitcoind]
bitcoind.rpchost=127.0.0.1:8332
bitcoind.rpcuser=wittyusername
bitcoind.rpcpass=VerySecretSuperDuperRPCauthPassword
bitcoind.zmqpubrawblock=127.0.0.1:28332
bitcoind.zmqpubrawtx=127.0.0.1:28333

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.