I'm trying to migrate my bitcoin node from version 0.16.1 to version 0.17.0 in Centos7.

he descargado todo del sitio oficial, al igual como lo hice con la vesion 0.16.1. y he ejecutado el daemon ./bitcoin-0.17.0/bin/bitcoind -daemon. until this point everything is fine.

The problem is that when I try to make the connection by RPC I reject the connection.

  • I tried to turn off version 0.17.0 and start the 0.16.0 and the RPC connection works fine.

Do I have to add something else to the configuration?

My config file is:

testnet=1
rpcconnect=127.0.0.1
daemon=1
maxconnections=20
maxuploadtarget=20
server=1
rpcuser=u************o
rpcpassword=a*******9
rpcauth=user:6*************************$
prune=0
keypool=600
rpcport=8332
  • Remote RPC is very dangerous and you could lose your money and/or privacy. So don't do it at all unless you know what you're doing. Read the release notes. I think they changed something to make behaviour more safe unless you specifically opt for unsafe settings (hopefully implying you know what you're doing). – Jannes Nov 18 at 16:55
  • If you look at my settings, you can only access the local way, I have reviewed the documentation, but I do not see anything new in version 0.17.0 that could be affecting. – La Thortilla Nov 18 at 19:54
  • On my 0.16.1 node the help says: -rpcbind=<addr>[:port] This option is ignored unless -rpcallowip is also passed. – Jannes Nov 18 at 20:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.