anyone ever had a similar issue where the directory exists but bitcoin-cli isn't recognizing it? Perhaps this is related to me setting the folder up as a symlink to my external HDD?

Thank you! aaronson

-Mac-mini:~ $ bitcoin-cli -regtest generate 1
Error reading configuration file: specified data directory "/Users/---/Library/Application\ Support/Bitcoin" does not exist.
-Mac-mini:~ $ cd /Users/---/Library/Application\ Support/Bitcoin
-Mac-mini:Bitcoin $ ls
banlist.dat bitcoind.pid    chainstate  db.log      peers.dat
bitcoin.conf    blocks      database    debug.log   wallet.dat
  • Do not use backslash and space symbols in folder name – amaclin Nov 30 '18 at 19:12
  • @aaronson If that was the solution, can either of you turn it into an answer so it can be marked accepted? – Pieter Wuille Dec 1 '18 at 18:02

Do not use backslash and space symbols in folder name


I just encountered this issue, too, and removing spaces (escaped or otherwise) appears to have solved the issue.

Like the OP, I was using a path containing Application\ Support.

$HOME/Library/Application\ Support/Bitcoin is the MacOS default, though, so hopefully most people won't need to set that explicitly.

  • Curiously, though, datadir seems to be autogenerated in my bitcoin.conf file every time I run bitcoind. That leads to issues on future runs whenever I'm using the default path, which contains Application Support – CypherPoet Dec 20 '18 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.