-1

When I call estimatefee 1 in testnet it returns: -1

According to docs:

If the node doesn’t have enough information to make an estimate, the value -1 will be returned

But on my bitcoin-cli getblockchaininfo, my verificationprogress is: 0.9999960537430175

What am I missing?

  • Downvoter why? I already said that I know the reason? Pathetic! – truongnm Jan 7 at 2:56
1

From the doc:

-1 is always returned for nblocks == 1 as it is impossible to calculate a fee that is high enough to get reliably included in the next block

https://bitcoincore.org/en/doc/0.16.0/rpc/util/estimatefee/

  • But my node is running quite long and my verificationprogress is: 0.9999960537430175 – truongnm Jan 4 at 3:39
  • No, it means for "estimatefee N", N must be larger than one, or it'll return -1. – MCCCS Jan 4 at 4:34
  • Of course I ran with N larger than one, but no matter what number I entered, I get the same returned result – truongnm Jan 4 at 4:57
  • Just get this error again after I restart my PC – truongnm Jan 24 at 8:30
0

Seem that after I restart my PC then things worked!

  • I just get this error again and restart my PC doesn't work! – truongnm Jan 24 at 7:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.