1

I'm getting the an electrum 3.3.2 error with something to do with dust.

the transaction was rejected by network rules dust error

I'm using the cli to send out a transaction and its just using 1 input and 1 output only. And the fee is auto set. It was working fine yesterday. I read it's something to do with the node. But what is wrong with it? I tried many other public nodes and it says the same error. What is happening? An attack?

What solutions are there for something like this? My application depends on having electrum working at all times.

result = server.runcmdline(configoptions)
  File "/xxxx/Desktop/Electrum-3.3.2/packages/jsonrpclib/jsonrpc.py", line 650, in call
    return self.send(self.name, args)

  File "/xxxx/Desktop/Electrum-3.3.2/packages/jsonrpclib/jsonrpc.py", line 532, in request
    checkforerrors(response)

  File "/xxx/Desktop/Electrum-3.3.2/packages/jsonrpclib/jsonrpc.py", line 1220, in checkforerrors
    raise ProtocolError((code, message))

jsonrpclib.jsonrpc.ProtocolError: (-32603, 'Server error: File "/home/xxx/Electrum-3.3.2/packages/aiorpcx/session.py", line 501, in sendrequest | aiorpcx.jsonrpc.RPCError: (1, \'the transaction was rejected by network rules.\\n\\ndust (code 64)\\n01000000......70800\')\n')
  • What was the transaction you are trying to send? Did you create it with Electrum or with something else? This has nothing to do with other nodes nor an attack. It just means that the transaction you created has an output whose value is below the dust limit. – Andrew Chow Jan 18 at 22:39
  • It's created with electrum running the cli commands. The fee is auto set, I don't know why it would be below the dust limit if it auto sets the fee. It was working fine yesterday using the same address input/outputs. – Patoshi パトシ Jan 18 at 22:44
  • This is not an issue with the amount of fees you are paying. This error is caused by the amount being sent being below the dust limit. This can happen if you are trying to send a very small amount, or if you are subtracting the fee from the outputs. Is the fee coming out of the amount you are trying to send? – Andrew Chow Jan 18 at 22:47
  • oh ok. i see what you mean. yes I was sending a very small amount of btc to test. where can I find the dust limit of a transaction amount? – Patoshi パトシ Jan 18 at 22:50
  • 1
    The dust limit is the cost of creating and spending the output at a fee rate of 3 sat/byte. That fee rate is not related to your transaction at all and is instead a setting that node operators can change. The default is 3 sat/byte. For a P2PKH output, that's 546 satoshis. For P2WPKH, it's 294 satoshis. – Andrew Chow Jan 18 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.