1

I'm using npm bitcoin-core ^2.0.0 to get access to my bitcoind (v0.17.1 MAC)

My code:

let signedRawTx = await btcClient.signRawTransaction(rawTx, [], [privateKey], 'ALL');

I get an error message telling me that signrawtransaction is deprecated, use signrawtransactionwithkey instead.

My problem: I tried to mixed uppercase letters like this:

btcClient.signRawTransactionWithKey(...)
btcClient.signrawtransactionwithkey(...)
btcClient.signRawTransactionWithkey(...)
...

with always the same kind of error:

signRawTransactionWithKey is not a function...

In my text editor, I can see all the available functions for btcClient, signRawTransaction is in the list but nothing like signRawTransactionWithKey. If I type help in the console of bitcoind, I can see signrawtransaction and signrawtransactionwithkey.

Any advice ?

1

It looks like the new calls are not yet supported in btcClient.

https://github.com/ruimarinho/bitcoin-core/issues/77 refers generally to your issue.

v2.0.0 was released "a year ago" according to https://www.npmjs.com/package/bitcoin-core; v0.17 bitcoind, which made the change, four months ago.

If you're just tinkering, you might consider downgrading your bitcoind until the library catches up.

  • 1
    OK, until then, I will use this flag in bitcoin.conf: deprecatedrpc=signrawtransaction – jfjobidon Feb 1 at 0:23
  • 1
    This is probably a sign that you should not be using this library-- it's un(der)maintained, ... – G. Maxwell Feb 2 at 3:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.