2

Brand new Raspberry Pi mainnet node following this walkthrough:

https://medium.com/@meeDamian/bitcoin-full-node-on-rbp3-revised-88bb7c8ef1d1

When I run this command:

bitcoin-cli -rpcuser=username -rpcpassword=password -rpcport=8332 getblockchaininfo

I receive the error:

error: Could not connect to the server 127.0.0.1:8332

When I tail debug.log, the node appears to be fully sync'd and picking up new blocks

My bitcoin.conf file is:

#is required for Fail2Ban logips=1

#magic RBP optimizations maxconnections=40 maxuploadtarget=5000

upnp=1

server=1 rpcuser='username' rpcpassword='password' rpcport='8332'

walletrbf=1

My apologies if my formatting is bad here, couldn't figure out how to get the .conf to paste as a block of text. Thank you for any ideas on what I'm doing wrong!

  • 1
    I guess checking your debug.log in your Bitcoin datadir ~/.bitcoin may give you some answers – Jonas Schnelli Feb 14 '19 at 6:45
  • 1
    I think having single quotes in the values for rpcuser, rpcpassword, and rpcport in your bitcoin.conf file is causing problems. Try removing those quotes and restart bitcoind. – Andrew Chow Feb 14 '19 at 17:40
  • 1
    The single quotes were it -- thanks so much! – user97315 Feb 15 '19 at 3:29
0

I encountered this error message when I have not started bitcoind.exe.

Starting bitcoind.exe solved the problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.