0

Fully synced on testnet blockchain after building Bitcoin with UI and wallet enabled on Ubuntu 18.10.

Pressing Send and Receive buttons results in no UI displayed.

Receiving addresses dialog doesn't have New button in this version so it can't be used.

Debug window getnewaddress worked, however, and I was able to receive some coins from coinfaucet.eu using that address.

After receiving coins Send button still doesn't result in any UI displayed. Receiving addresses menu/resulting dialog now shows the address that coins were received at (the one obtained via getnewaddress).

I see the same behavior of buttons when synced on the main net but couldn't test sending or receiving the real Bitcoins.

What can I do to debug this issue without getting deep into the (quite unfamiliar at this point) source code? I compiled bitcoin with optimizations enabled.

Here is a link to the debug.log created in the following way: exited bitcoin-qt and renamed original log which was huge. Restarted bitcoin-qt with options -testnet -debug=1. Clicked on Send, Receive and Transactions buttons. Exited bitcoin-qt.

  • To get addresses, you need to go to the receive tab and click the Request Payment button. For the sending issue, can you show a screenshot/video of what you are doing? – Andrew Chow Feb 25 at 6:33
  • @AndrewChow I don't see Request Payment button either. This is tabbed interface? I'll try to create animated GIF but it won't show you much beside that clicking on Send, Receive and Transaction buttons still shows the Overview page.Tabs in Debug window work, however. This may be Ubuntu 18.10 UI specific. I'll try link to data dir from older Ubuntu install to verify that. – Tony Feb 25 at 23:56
  • Clicking Send, Receive, and Transactions should show different pages. Can you also post your debug.log file? Using a different datadir won't make a difference. Nothing stored in the datadir effects how the UI behaves. – Andrew Chow Feb 26 at 4:30
  • @AndrewChow added link to debug.log at the bottom of the post. Regarding datadir I meant running UI from older Ubuntu but pointing to datadir on USB SSD which has Ubuntu 18.10 and where I built bitcoin-qt, to avoid downloading the blockchain from scratch. – Tony Feb 26 at 11:17
  • Is this self compiled or using the official release binary from bitcoincore.org? If self compiled, what version of Qt do you have installed? (you should be able to get this from Bitcoin Core by going to Help > About Qt. – Andrew Chow Feb 26 at 16:33
0

I believe I should answer this question for the people who may stumble here and would like to know right away what is this issue all about.

If you are building from source and configure your build like:

./configure --with-gui --disable-wallet --SOME-OTHER-OPTIONS

and then you decide you want the wallet and go back to configure and rebuild without --disable-wallet, that is:

./configure --with-gui --SOME-OTHER-OPTIONS

make sure you run make clean before rebuilding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.