0

started fresh a new lightning node using the raspiblitz guide but while synching the client from my desktop pc (MAC) i wasnt able to locate these files ( “.indexes .testnet3” ) required by the guide to properly synch the client on the pi. It’s weird those files arent anywhere in ~/library/Application Support/Bitcoin/

I’m running the latest bitcoin core version .17.1 and one of the most requirements of the guide when copying the blockchain from the latest version is ( txindex=1 in the bitcoin.conf) but i didnt modify the .conf at all since it should be by default with the latest version...

Any ideas where to locate those files in Mac?

  • Are you running it in testnet mode? Has it finished indexing? – JBaczuk Feb 25 at 12:51
  • No, im running it on the mainet and i checked the directory few minutes after it synched, but this wasnt my first time, i resynchs it on my mac from times to times but this time i did it only to copy it to the pi. – Lebowski Feb 25 at 12:53
  • The testnet folder will not exist if you have not run testnet – JBaczuk Feb 25 at 13:17
  • Well, tbh im not using it either on testnet nor mainet, i just needed the synched blockchain that’s all. What about that indexes folder? Cuz i realized theres a folder called “index” within the blocks folder but i dont think that’s the one the guide mentions. – Lebowski Feb 25 at 13:20
  • a link to the guide would help – JBaczuk Feb 25 at 15:02
0

but i didnt modify the .conf at all since it should be by default with the latest version...

There is no default bitcoin.conf file nor is txindex enabled by default.

Without enabling txindex in the bitcoin.conf file, the indexes folder will not be created as the txindex is not being created.

There won't be a testnet3 folder if you are not running it in testnet mode.

Well, tbh im not using it either on testnet nor mainet,

The default is mainnet. Mainnet is not a different special mode. Furthermore, "the blockchain" is tied to a network. It is not a shared blockchain between testnet and mainnet.

If you have not modified the bitcoin.conf file or started bitcoind with special options, you are using mainnet without the transaction index, so neither the testnet3 folder nor the indexes folder will appear.

  • Oh, thanks for the heads up... i thought the indexes folder was by default part of the bitcoin folder, but ok now i know that i should modify/add the txindex=1 to the bitcoin.conf in order to have the folder. – Lebowski Feb 25 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.