0

I have a bitcoin core full node version 0.17.1 running on my machine. I want to enable prune on the node to save space on the disk. When I apply -prune=15000 in bitcoin.config file and restart bitcoin core GUI, it shows -txindex is incompatible with prune. So I want to start my node with prune enabled. Is there any way for that?

1

By pruning the blockchain you:

Reduce storage requirements by enabling pruning (deleting) of old blocks. This allows the pruneblockchain RPC to be called to delete specific blocks, and enables automatic pruning of old blocks if a target size in MiB is provided. This mode is incompatible with -txindex and -rescan. Warning: Reverting this setting requires re-downloading the entire blockchain. (default: 0 = disable pruning blocks, 1 = allow manual pruning via RPC, =550 = automatically prune block files to stay under the specified target size in MiB)

So, -txindex cannot be enabled when the blockchain in pruned

  • I tried to update property of .exe file like "C:\Program Files\Bitcoin\bitcoin-qt.exe" -prune=150000 -reindex, and started bitcoin core application on windows server 2012. But still I am getting error that Prune mode is incompatible with -txindex. – Sagar Moharil Mar 7 at 13:36
  • 1
    Hey, I updated my answer. It seems txindex cannot run together with prune. This is the help message from bitcoind – Ugam Kamat Mar 7 at 13:50
  • I don't want to run -txindex, what I want is to run Bitcoin core wallet after prune is enabled. So is there any way to start node after we specify prune? – Sagar Moharil Mar 8 at 5:02
  • Check your bitcoin.conf file. There is a high likelihood that you have -txindex=1 over there which is why it is popping out the error. – Ugam Kamat Mar 9 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.