0

I have tor running as a service on my computer and start bitcoind with -proxy=127.0.0.1:9050 but it fails to find any seeds through DNS or anything during startup, and even after leaving it on for more than a day it still not finding peers. I'm not getting any errors with connection or anything, and if I change port to for example 9051, it complains indicating that tor is running ok. Also, if I run it without the proxy option I get peers immediately and syncing starts right away. Can someone please help me? I'm running 0.17.1.

Here is also a little bit of the console print during startup. I was running it without proxy right before this so it got a few blocks:

2019-03-12T00:45:31Z Loaded 8954 addresses from peers.dat  23ms
2019-03-12T00:45:31Z init message: Loading banlist...
2019-03-12T00:45:31Z init message: Starting network threads...
2019-03-12T00:45:31Z addcon thread start
2019-03-12T00:45:31Z init message: Done loading
2019-03-12T00:45:31Z net thread start
2019-03-12T00:45:31Z opencon thread start
2019-03-12T00:45:31Z dnsseed thread start
2019-03-12T00:45:31Z msghand thread start
2019-03-12T00:45:42Z Loading addresses from DNS seeds (could take a while)
2019-03-12T00:45:42Z 0 addresses found from DNS seeds
2019-03-12T00:45:42Z dnsseed thread exit
2019-03-12T00:46:02Z Syncing txindex with block chain from height 13187
0

Have you confirmed that tor is working correctly, say with a web browser? Temporarily set it to use a SOCKS5 proxy at 127.0.0.1:9050.

For more verbose information, try starting bitcoin with

commandline: -debug=1 or -debug=tor

bitcoin.conf: debug=1 or debug=tor

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.