0

This is what my conf file looks like:

prune=600
maxconnections=12
maxuploadtarget=20
rpcuser=user
rpcpassword=password
keypool=10000
server=1

[main]
rpcport=5040

Whenever I run this from the command line I get the following error:

Binding RPC on address ::1 port 5040 failed.

Binding RPC on address 127.0.0.1 port 5040 failed.

I checked for port 5040 using the netstat -a and it was listening, what's the problem?

  • Are you sure nothing else is using port 5040 already? – Raghav Sood Mar 21 at 23:42
  • Please post the results of running sudo lsof -i | grep 5040 – Alistair Mann Mar 21 at 23:49
  • My OS is Windows 10, not linux – frogman578 Mar 22 at 7:10
0

Windows 10

Run netstat -ab >file.txt then notepad file.txt and search on 5040. I suspect you will find CDPSvc immediately underneath - on my machine this "Connected Devices Platform Service" is already using your port.

If that's so, search on 5041, then 5042 and continue up until search can't find it. That port is free: change your rpcport to match it.

  • Nothing happens when I run that command – frogman578 Mar 24 at 19:10
  • There are two commands. – Alistair Mann Mar 24 at 22:46
  • I don't quite understand, could you elaborate more? – frogman578 Mar 25 at 18:36
  • 1/4: Open up an Admin Command Prompt – Alistair Mann Mar 25 at 22:13
  • 2/4: Type netstat -ab >file.txt into the Command Prompt, then press return. This is the first command and you do not expect something to happen: the >file.txt element tells Windows to save the ordinary output into a file in the current directory called file.txt. You're doing this because the ordinary output will overflow the Command Prompt buffer and you'll lose the initial output. – Alistair Mann Mar 25 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.