0

I Just try to enable SSL for bitcoin-qt RPC call. I follow the SSL on RPC link to archive my target. But I am getting the following error and close the bitcoin-qt automatically.

enter image description here

I am using the bitcoin-qt 0.16.3

1

Support for SSL protected RPC was removed in Bitcoin Core version 0.12.0 (released in february 2016).

See https://bitcoin.org/en/release/v0.12.0#rpc-low-level-api-changes for the release notes on this, and also a workaround.

  • Thanks for answering. I don't understand why Bitcoin core developer is remove the SSL supported RPC on new versions...?? Actually it is decrease the security..?? – salman faris Apr 8 at 14:29
  • 1
    Generally the RPC interface is intended for locally running services that you trust. It isn't designed to be exposed over the internet. If you have a need for that, it's probably better to develop a wrapper with protections in yourself (for example, not exposing dumpprivkey or importmulti or even `stop). – Pieter Wuille Apr 8 at 14:36
  • But actually I need to run it remotely. Any way are available to enable SSL for RPC call for bitcoind...??? – salman faris Apr 9 at 3:21
  • Using of Bitcoind version 0.11 is a solution for my problem ..??? – salman faris Apr 9 at 3:22
  • 1
    @salman farris The release notes I linked to explain how it can be done using stunnel or apache. Please, do not use 0.11. It is no longer maintained and has several critical issues. – Pieter Wuille Apr 9 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.