0

I always struggle here and tried both ways plenty of time

i use the rubygem "moneytree" and electrum 3.3

@master = MoneyTree::Master.new
@master.to_bip32(:private)

this will give me tprv8ZgxMBicQKsPe8hnfLVQdtZk2qMKnnDQs2ZKLgoJQBhedKQ5vB7srAb6Tk2iUYNkhaacTjNP9WzkbjCqPjk8ExUFGECbiR1Z8tZDs76jytn

however, i can't import this in electrum. the next button is just non active.


i tried the other way around and created a wallet with seed fabric body bright coffee special music virus raccoon side double shield shrug and exported the master public key which will gives me xpub661MyMwAqRbcGq54zC5FfD3rTjgcAGd36JvtW6r4RGheQjSdUVqAS9Q1DLAvzyvvxdYziZced4Y6kHLCqo73vuB4gGSpt6tJwtCWYm8zsBb

now i'll run the following

master_pub_key = "xpub661MyMwAqRbcGq54zC5FfD3rTjgcAGd36JvtW6r4RGheQjSdUVqAS9Q1DLAvzyvvxdYziZced4Y6kHLCqo73vuB4gGSpt6tJwtCWYm8zsBb"
$bitcoin_root_node = MoneyTree::Node.from_bip32(master_pub_key)

i = 0
20.times do
  p $bitcoin_root_node.node_for_path("m/0/#{i}").to_address
  i+= 1
end

all generated addresses will look like this

mpQPcBLyTqPPCw9dhdXYm3Dvnnn58Y4dwA
mt6UdprJNAuJUtG3BYWTy3dZrST7nZTwtZ

starting with a small M

however, in electrum all the addresses are starting with 1xxxxx

what am i doing wrong?

1

It looks like in some places you're using testnet addresses (tprv.., m..) and in other places you're using mainnet addresses (xpub.., 1..). If your software is expecting one and gets the other, then you'll likely have some problems (like Electrum not letting you click 'next'). Check to make sure all the software you're using is configured to give you the desired outputs.

See: https://en.bitcoin.it/wiki/List_of_address_prefixes

  • thanks buddy. i used my own fork where i made testnet true unless specified otherwise. i forgot about. i'm so stupid :) – huan son May 10 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.