0

Here's goes the steps that lead me to a wallet passphrase error:

OS: Mac Mojave (64bits)

  • Started bitcoin-qt app to sync (long outdated)
  • While managing to solve disk size errors (external drive), I updated bitcoin-qt to the latest version (18), but not sure what the previous one version was (perhaps 16.0).
  • As soon sync finished, I choose to encrypt my wallet :(.
  • I saved my passphrase, as it was created (100% sure!). To make sure it works, I changed the passphrase twice, but making sure the last change was the one I saved previously.
  • As bitcoin base was huge in my external drive, I set prune mode on (550).
  • All set, asked to received from my exchange.
  • Finally, when I tried to send the received amount, bitcoin-qt asked me the wallet passphrase, were I got the wrong passphrase error...

    Is the only cause for that the wrong passphrase ? I mean, I'm sure I have typed the right one...

1

I'm assuming you've already tried caps lock, the intermediate passwords you used etc.

Ideally you would backup your wallet before making changes such that you have a library of them: wallet.dat.1jun2018, wallet.dat.2jul2018 etc. Then if something goes wrong, you already know that the previous copy of the wallet is still available.

I can't tell what's gone wrong for you from your description above, but OSX Mojave does offer some facilities. First, you MUST copy your wallet as it currently stands - even though you don't have the password - to an external disk, date it as above. Then use Time machine even if you haven't been using it to have a look at the folder ~/Library/Application Support/Bitcoin. Mojave stores local backups on your computer "even when your Time Machine backup disk isn't available." You're hoping to see that wallet.dat is available from a date prior to the encryption.

If it is, then you might try restoring it. Also copy it under a new name to your external disk. You might be lucky enough that bitcoin-qt works straight away without the password. If you can restore a previous version but cannot seem to use it, things start to get a lot more tricky, very quickly.

If you don't have the local backups, or the wallet isn't within it, I would turn the computer off and sleep on it. When you get up, write down everything you did, every password you tried, in the hope that something jogs your memory.

  • Alistair, thanks for your reply. I found a wallet there, but I'm getting this error "last wallet synchronisation goes beyond pruned data" and say I need to reindex... – mike May 17 at 0:45
  • 1/ That you found a wallet there sounds like good news. I know nothing of your abilities and your set up so my suggestion is that you go back even further in the time machine and recover the wallet file from further and further back, copying them under an appropriate name to your external disk. – Alistair Mann May 17 at 8:52
  • 2/ I would then suggest not that you fix the current install, but rather create a new user (much better if this can be on a second machine), and install v16 to that - then copy successively older wallets to there instead. By this means is it left open to have specialist recovery services examine the original install. – Alistair Mann May 17 at 8:58
  • Can't download 0.16 from an official source: bitcoincore.org/bin/bitcoin-core-0.16.0 That's frustrating... – mike May 17 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.