1

my bitcoin.conf:

server=1
rpcauth=myusername:e2aa83d74a55b7addfe070367546e72d$953dda2b7e2d5a151a7ef0e82ed50a734bf4c4ac55289fede8bd340489d5af0f
rpcallowip=46.101.245.27clientip address
datadir=/mnt/volume_fra1_03/

my cliend side options:

BITCOIND_SCHEME=http
BITCOIND_HOST=142.93.165.221
BITCOIND_PORT=8332
BITCOIND_USER=myusername
BITCOIND_PASSWORD=mysecretpassword

everything is correnct but i get connection refused error. on serverside 8332 is open and bitcoind listen. bitcoin-cli getblockchaininfo is working. bur i try connect remotely i geer error connection refused.

2

Try setting rpcbind to the same ip address as rpcallowip. I believe the behavior of those options changed recently with 0.18.0, https://github.com/bitcoin/bitcoin/blob/master/doc/release-notes/release-notes-0.18.0.md.

The rpcallowip option can no longer be used to automatically listen on all network interfaces. Instead, the rpcbind parameter must be used to specify the IP addresses to listen on. Listening for RPC commands over a public network connection is insecure and should be disabled, so a warning is now printed if a user selects such a configuration. If you need to expose RPC in order to use a tool like Docker, ensure you only bind RPC to your localhost, e.g. docker run [...] -p 127.0.0.1:8332:8332 (this is an extra :8332 over the normal Docker port specification).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.