I made a transaction of 1.22242 mBTC with the electrum client and, I don't know why, it looks like it transferred all the remaining BTC from my account to myself which made a 13063 bytes transaction and costs me 8.43769 mBTC... Do you know what happened?


  • Your account has received a large number of very small payments. That's going to make for some very high transaction costs as you have to gather all those tiny payments together. If all those tiny payments are coming from the same place, see if you can get them to make a smaller number of larger payments to save you money. Commented Jun 17, 2019 at 17:35
  • Thanks for the tip, most of the transactions came a long time ago from "faucets", websites that give away a tiny amount of bitcoin for free.
    – dki
    Commented Jun 17, 2019 at 22:21
  • @dki yeah those are mostly scams because you can't really spend that money without paying disproportionately large amounts in fees.
    – Abdussamad
    Commented Jun 22, 2019 at 18:39

2 Answers 2


This is a process known as consolidation - If your wallet has several small inputs, many wallets will often try to combine them into a single change input during regular transactions, especially ones made with a low sat/byte feerate. This allows you to spend the coins in a smaller transaction during possibly high traffic times, when the feerate may be much higher.

These days, many wallets only perform such consolidation if there are many outputs to a single address, as combining outputs from multiple addresses unnecessarily can lead to a loss of privacy. Unfortunately for you, it seems like in your case all the outputs do belong to a single address.

In the case of electrum, this doesn't appear to be a configurable option, although you could notice it is happening prior to submitting the transaction by using the "Preview" option - if you notice that the total fee or size or number of inputs consumed it too large, you can force electrum to build a transaction using only specific inputs by selecting them in your transaction history, then right clicking and selecting the spend from option.


The problem is the transaction fee doesn't depend on the values of inputs, but the number of inputs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.