1

I am trying to send transaction using bitcoin-cli but I am constantly getting:

admin@XXXX:~$ bitcoin-cli sendtoaddress "XXXXXXX" 0.1 "" "" false true 5 "ECONOMICAL"
error code: -4
error message:
Fee estimation failed. Fallbackfee is disabled. Wait a few blocks or enable -fallbackfee.

I do not wish to set up fallbackfee. I want my running bitcoind to estimate the fees based on what is currently going on in the network and based on my confirmation target (5 in this case)

Any idea what is going on and how fix this? Thanks!

P.S. My blockchain is fully synced.

EDIT: after some digging, can blocksonly=1 option in my bitcoin.conf be blamed? Look at my mempool info

bitcoin-cli getmempoolinfo
{
  "size": 0,
  "bytes": 0,
  "usage": 0,
  "maxmempool": 300000000,
  "mempoolminfee": 0.00001000,
  "minrelaytxfee": 0.00001000
}

such empty :(

3

You can’t estimate a fee without a mempool, so blocksonly mode will cause this failure. Explicitly you don’t download transactions with this turned on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.