0

I'm trying to create a channel using c-lighting (testnet), but I keep getting an Unknown Peer error message.

  • I used cli/lightning-cli connect which seemed to work fine.
  • I used cli/lightning-cli listnodes and I see whole bunch of nodes.
  • I used cli/lightning-cli listpeers and I see 1 peer.
  • I used cli/lightning-cli newaddr to create a new address and funded it (3 confirms so far)
  • I then try to use cli/lightning-cli fundchannel and I get an Unknown Peer message.
1

Everything but the last Comand looks correct. There is no command channel in c-lightning. In order to open a channel you need to execute

cli/lightning-cli fundchannel id satoshi [feerate] [announce] [minconf]
  Fund channel with {id} using {satoshi} (or 'all') satoshis, at optional {feerate}. Only use outputs that have {minconf} confirmations.

The thing that beginners sometimes oversee is that before opening a channel with a node you need to peer with it first via the connect command like you did.

  • That was a mistake in the question, I did do fundchannel which is what gives the Unknown Peer error. Any other tests I can do to try to figure out why this is happening? – oshirowanen Jul 17 at 21:27
  • can you post information from the logfile? (with loglevel debug?) – Rene Pickhardt Jul 18 at 7:33
  • 1
    Got it working. I was making a noob mistake in that I did not realise that the connect address and the fundchannel address had to be the same... – oshirowanen Jul 18 at 15:59
  • Yes, that is quite a common mistake. It could also have been that between the connect and the fundchannel command the connection was lost, e.g., the remote peer closed the connection. In that case you would have had a connection on which to open a channel, but when attempting to fund the channel it'd be already gone again, – cdecker Aug 3 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.