0

I used "sudo snap install bitcoin-core" and it appeared to install fine except I get the error: "Failed to launch 'Bitcoin Core' Desktop file didn't specify Exec Field." Did I do something wrong? Maybe I am not finished with the install?

This is nearly a pristine installation of Ubuntu. The only other thing I did was run updates and I installed Konsole prior to installing Bitcoin Core. I ran the "sudo snap install..." command from Konsole.

Thanks to all.

0

This must help you.

Open terminal:

$ sudo su
# cd /var/lib/snapd/desktop/applications
# nano bitcoin-core_bitcoin-qt.desktop

and last line must look like that

Exec=env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/bitcoin-core_bitcoin-qt.desktop /snap/bin/bitcoin-core.qt %U

Ctrl + X will quit the editor and you will be asked if you want to save your changes. Press Y for Yes.

Now try launching the app.

0

From the command line, I typed '/snap/bin/bitcoin-core.qt' and now Bitcoin Core is synchronizing with the network. Problem solved.

I still don't know how to repair the shortcut but that is because I'm a Linux newbie.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.