1

I'm following the RaspiBolt guide to setup a lighting node.

But when I start lnd and unlock the wallet, the applications fails:

2019-08-03 11:28:08.659 [INF] LNWL: Opened wallet
2019-08-03 11:28:08.834 [INF] LTND: Primary chain is set to: bitcoin
2019-08-03 11:28:08.854 [INF] LNWL: Started listening for bitcoind block notifications via ZMQ on 127.0.0.1:28332
2019-08-03 11:28:08.855 [INF] LNWL: Started listening for bitcoind transaction notifications via ZMQ on 127.0.0.1:28333
2019-08-03 11:28:08.855 [INF] LTND: Initializing bitcoind backed fee estimator
2019-08-03 11:28:11.405 [INF] LNWL: The wallet has been unlocked without a time limit
2019-08-03 11:28:11.450 [INF] LTND: LightningWallet opened
2019-08-03 11:28:11.511 [INF] HSWC: Restoring in-memory circuit state from disk
2019-08-03 11:28:11.514 [INF] HSWC: Payment circuits loaded: num_pending=0, num_open=0
2019-08-03 11:28:11.514 [INF] SRVR: Scanning local network for a UPnP enabled device
2019-08-03 11:28:12.596 [INF] LNWL: Started rescan from block 00000000000002d827c114842ad95643d9d839ee9c09382cd2be7db27126f250 (height 1572184) for 0 addresses
2019-08-03 11:28:18.158 [INF] LNWL: Catching up block hashes to height 1572362, this might take a while
2019-08-03 11:28:18.167 [INF] LNWL: Done catching up block hashes
2019-08-03 11:28:18.167 [INF] LNWL: Finished rescan for 0 addresses (synced to block 0000000000000142bf3e7429ad7d93ba2f48b1ba02d5aeff684cd064f3070655, height 1572362)
2019-08-03 11:28:21.520 [ERR] SRVR: Unable to discover a UPnP enabled device on the local network: context canceled
2019-08-03 11:28:21.520 [INF] SRVR: Scanning local network for a NAT-PMP enabled device
2019-08-03 11:28:21.581 [ERR] SRVR: Unable to discover a NAT-PMP enabled device on the local network: read udp 192.168.1.10:48055->192.168.1.1:5351: recvfrom: connection refused
2019-08-03 11:28:21.582 [ERR] LTND: Unable to create server: Unable to discover a NAT-PMP enabled device on the local network: read udp 192.168.1.10:48055->192.168.1.1:5351: recvfrom: connection refused
2019-08-03 11:28:21.582 [INF] LTND: Shutdown complete
Unable to create server: Unable to discover a NAT-PMP enabled device on the local network: read udp 192.168.1.10:48055->192.168.1.1:5351: recvfrom: connection refused

My router, ZTE F680 does has UPnP enabled. Why can not find it?

  • UPnP does not always work nicely with LND, for reasons unknown to me. Try port forwarding, it is more reliable. – Dmitry Laptev Aug 4 at 12:24
  • I've tried the proposals from here github.com/Stadicus/RaspiBolt/issues/301 but it didn't work for me. Neither disabling the ufw, the port 18333 is not open to outside. It must be something about my router. – anat0lius Aug 5 at 6:47
  • I'm behind a CG-NAT so I can not forward ports... – anat0lius Aug 8 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.