0

I am trying to compile oclvanitygen because I have an Nvidia GTX 1080 that would most likely be helpful for this. I'm using the Windows Subsystem for Linux with Ubuntu 18.04.

I tried this command: gcc oclvanitygen.o oclengine.o pattern.o util.o -o oclvanitygen -ggdb -O3 -Wall -L/usr/lib/x86_64-linux-gnu/ -lpcre -lcrypto -lm -lpthread -l:/usr/lib/x86_64-linux-gnu/libopencl.so.1

It basically says that libopencl.so.1 does not exist. However, I have libnvidia-opencl.so.1, so I try this command: gcc oclvanitygen.o oclengine.o pattern.o util.o -o oclvanitygen -ggdb -O3 -Wall -L/usr/lib/x86_64-linux-gnu/ -lpcre -lcrypto -lm -lpthread -l:/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1

Then it says /usr/bin/ld: cannot find -l:/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1

So I do a list of x86_64-linux-gnu, and there it is, clear as day. list of x86-64-linux-gnu

How can I compile this correctly? Here is a picture of what happens when I run the command: GCC Command

I have installed the ocl-icd-opencl-dev package, but it does not include libopencl.so.1.

Please tell me if I am doing something wrong. Thanks!

0

Perhaps, if you want to generate a vanity address, I suggest you use Vanitygen Plus

https://github.com/exploitagency/vanitygen-plus (More up to date and features)

and to compile, run make -f Makefile after u clone the repo and cd into it.

  • Yes, but can I compile oclvanitygen from it? – Yoshi24517 Oct 1 at 2:00
  • I have it, but I'm still getting an error code of -1001 when I look for opencl gpus when I installed cuda 10 on ubuntu. – Yoshi24517 Oct 1 at 2:08
  • Vanitygen-plus is newer and more feature than legacy Vanitygen (which is ~7-8 years ago). So yes it more stable and has same feature as Vanitygen. Also, you should also use Makefile to compile the source instead using gcc to compile it since it has all the required configuration it needed to compile. – zhiyan114 Oct 1 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.