0

On Ubuntu 18.04 using the /depends for ./configure but I keep getting this error:

checking for boostlib >= 1.47.0 (104700) includes in "/home/tony/crypto/bitcoin/depends/x86_64-pc-linux-gnu/share/../include"... yes
checking for boostlib >= 1.47.0 (104700) lib path in "/home/tony/crypto/bitcoin/depends/x86_64-pc-linux-gnu/share/../lib/x86_64-linux-gnu"... no
checking for boostlib >= 1.47.0 (104700) lib path in "/home/tony/crypto/bitcoin/depends/x86_64-pc-linux-gnu/share/../lib64"... no
checking for boostlib >= 1.47.0 (104700) lib path in "/home/tony/crypto/bitcoin/depends/x86_64-pc-linux-gnu/share/../libx32"... no
checking for boostlib >= 1.47.0 (104700) lib path in "/home/tony/crypto/bitcoin/depends/x86_64-pc-linux-gnu/share/../lib"... yes
checking for boostlib >= 1.47.0 (104700)... yes
checking whether the Boost::System library is available... yes
checking for exit in -lboost_system-mt-x64... yes
checking whether the Boost::Filesystem library is available... yes
checking for exit in -lboost_filesystem-mt-x64... yes
checking whether the Boost::Thread library is available... yes
checking for exit in -lboost_thread-mt-x64... yes
checking whether the Boost::Chrono library is available... yes
checking for exit in -lboost_chrono-mt-x64... yes
checking whether the Boost::Unit_Test_Framework library is available... yes
checking for dynamic linked boost test... no
checking for mismatched boost c++11 scoped enums... ok
configure: error: No working boost sleep implementation found.

The command called is

./configure --prefix=`pwd`/depends/x86_64-pc-linux-gnu --disable-wallet

. I've tried this without the depends and with. Tried to checkout to 0.18.1 and on master, but getting same error. Help very much appreciated.


Extra info from config.log

uname -m = x86_64
uname -r = 4.15.0-65-generic
uname -s = Linux
uname -v = #74-Ubuntu SMP Tue Sep 17 17:06:04 UTC 2019

More from config.log here: https://paste.ubuntu.com/p/v6nhPvW68s/

  • Seems like the depends build wasn't completed. Try rebuilding the dependencies and see if there are any errors there. – Andrew Chow Oct 7 '19 at 2:36
  • @AndrewChow Running make in /depends gives me copying packages: boost openssl libevent qrencode zlib qt expat libxcb xcb_proto libXau xproto freetype fontconfig bdb miniupnpc zeromq to: /home/tony/crypto/bitcoin/depends/x86_64-pc-linux-gnu Doesn't seem to give any errors when building depends. – wednesdaymiko Oct 9 '19 at 15:51
  • Tried rebuilding twice by deleting /depends, doesn't seem to make a difference. – wednesdaymiko Oct 9 '19 at 17:05
0

Found the problem. Had these lines in my .bashrc and commenting them out fixed it:

alias gcc="gcc-8"
alias g++="g++-8"
export CC="gcc"
export CXX="/usr/bin/gcc-8"
export PATH=/usr/local/clang_8.0.0/bin:$PATH
export LD_LIBRARY_PATH=/usr/local/clang_8.0.0/lib:$LD_LIBRARY_PATH

Why this caused ./configure to error out, I have no idea. But problem solved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.