1

I am trying to use Bitcoin Core 0.18.1 on Linux Mint 19.2. I have previously used an older version on Win7 with no problems.

I have moved my old data directory to a new ext4 partition on an internal hdd. Bitcoin is installed on internal ssd. Everything was fine using default /home/admin1/.var/app/org.bitcoincore.bitcoin-qt/data/.

I cannot get the datadir parameter to work (-datadir=/mnt/WDRED/BitcoinData/). It keeps saying the folder does not exist. I tried deleting the default data folder and replacing it with a symlink to the actual folder on hdd but it says the same thing that the symlink folder does not exist.

Somebody might tell me ultimately I have done something stupid or I should have been able to figure it out myself but I have tried what I could from reading up and I am frustrated now. Thank you.

EDIT----

I have now solved the problem hopefully. I installed bitcoin core from within the native software manager in Linux Mint originally. This installed via flatpak. I subsequently read about flatpak and saw that it was running the application in a sandbox (from what I gather?) so I don't think it could see any path on my system that was not within that sandbox.

I uninstalled bitcoin core and reinstalled via snapd. That installation was able to obey the parameter as I expected it to so it is now verifying the existing block files and my problem (it seems atm) is solved...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.