I'm trying to set my first c-lightning node with docker-compose using image from https://hub.docker.com/r/elementsproject/lightningd. currently, my node can connect and open channel with other nodes (and I can open a channel to the node just fine), but it's still not updated (ie has no information) on most explorers.

the following is result of getinfo and listconfigs

   "id": "03db40337c2de299a8fa454fdf89d311615d50a27129d43286696d9e497b2b027a",
   "alias": "TestName",
   "color": "fff000",
   "num_peers": 3,
   "num_pending_channels": 0,
   "num_active_channels": 3,
   "num_inactive_channels": 0,
   "address": [
         "type": "ipv4",
         "address": "",
         "port": 9735
   "binding": [
         "type": "ipv4",
         "address": "",
         "port": 9735
   "version": "v0.7.1-906-gf657146",
   "blockheight": 601917,
   "network": "bitcoin",
   "msatoshi_fees_collected": 0,
   "fees_collected_msat": "0msat"

   "# version": "v0.7.1-906-gf657146",
   "lightning-dir": "/root/.lightning",
   "wallet": "sqlite3:///root/.lightning/lightningd.sqlite3",
   "plugin": "/usr/local/bin/../libexec/c-lightning/plugins/pay",
   "plugin": "/usr/local/bin/../libexec/c-lightning/plugins/autoclean",
   "plugin": "/usr/local/bin/../libexec/c-lightning/plugins/fundchannel",
   "network": "bitcoin",
   "allow-deprecated-apis": true,
   "always-use-proxy": false,
   "daemon": "false",
   "rpc-file": "lightning-rpc",
   "rgb": "fff000",
   "alias": "HubTest",
   "bitcoin-rpcuser": [redacted],
   "bitcoin-rpcpassword": [redacted],
   "bitcoin-rpcconnect": "bitcoind",
   "bitcoin-retry-timeout": 60,
   "pid-file": "lightningd-bitcoin.pid",
   "ignore-fee-limits": false,
   "watchtime-blocks": 144,
   "max-locktime-blocks": 2016,
   "funding-confirms": 3,
   "commit-fee-min": 200,
   "commit-fee-max": 2000,
   "commit-fee": 500,
   "cltv-delta": 14,
   "cltv-final": 10,
   "commit-time": 10,
   "fee-base": 0,
   "rescan": 15,
   "fee-per-satoshi": 1,
   "max-concurrent-htlcs": 30,
   "min-capacity-sat": 10000,
   "bind-addr": "",
   "announce-addr": "",
   "offline": "false",
   "autolisten": true,
   "disable-dns": "false",
   "enable-autotor-v2-mode": "false",
   "encrypted-hsm": false,
   "log-level": "DEBUG",
   "log-prefix": "lightningd(7):"

is there something wrong with this configuration? or is it another issue?

I understand that explorers update their node list irregularly, and as far as the node can open channels (and can be connected), everything is fine. but this thing has bugging me for weeks.

  • Your node is visible on explorers. I think what you mean to ask is why the explorers do not show additional data (like color, IP, alias) related to your node ID.
    – Ugam Kamat
    Nov 1, 2019 at 14:34
  • sorry, I must be confused with the definition. you are right, I'm wondering about alias color, and IP address. I'll update my question.
    – nhubest
    Nov 1, 2019 at 14:38

1 Answer 1


updated the docker image and put bind-addr to somehow fixed the problem for some unknown reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.