0

Hello I run bitcoind and i get this 8333 failed after select(): Connection refused (111). Can you help me with this? because it was working suddenly this happened.

3
  • my bitcoin.confıg is like this ( txindex=1 rpcuser=bitcoinrpc rpcpassword=saadia rpcbind=0.0.0.0 rpcallowip=0.0.0.0/0)
    – saadia
    Dec 19 '19 at 8:51
  • if you use the framework rpc the default port is 8332 Dec 19 '19 at 9:12
  • when I run as testnet it works but when İ run as main it failed to connect. where can i change the port? Thank you
    – saadia
    Dec 19 '19 at 9:17
1

this happens when you have a running daemon and suddenly for whatever reason the firewall starts blocking it. IT IS A FIREWALL ISSUE.

In my case I installed additional programs on my server which changed the settings of nftables (formerly iptables). I had to open up the relevant ports again (that are required by btc-daemon).

After that you have to restart both nftables as well as btcd.

Keep checking the logs for a few minutes. And you will see it will be running just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.