I am installing Bitcoin-Qt and have been reading about Bitcoin basics, but I found very little information on the client. I have a few questions about the Bitcoin-Qt program (v0.8.1-beta under Windows 7),

  1. Where is the complete Bitcoin-Qt documentation? I can not find it.
  2. How do I change the file locations for the block-chain storage?
    • Block chain is ~6 GB
    • The default appears to be MyDocuments\AppData\Roaming\
    • My C: system drive is small, and I have a second drive for such data.
  3. Is the "Wallet" a separate file/entity from the block-chain?
    • How do I define the wallet's location?
    • Can I backup the wallet by simple copy/paste/tar.gz without carrying the entire block-chain?
  4. Does the Bitcoin-Qt client currently have built-in mining/transaction-processing? I do not see the dialog-box to configure. I have a graphics card and ample wasted CPU-cycles.

Thanks for clarification. Links to proper documentation are welcome!

  • Where is the folder in Windows 8.1? He is not under AppData \ Roaming – user17072 Jun 4 '14 at 9:31
up vote 14 down vote accepted
  1. Here:

  2. Use the -datadir option.
    Right-click on your bitcoin-qt shortcut, press properties, and add -datadir=D:\Bitcoin
    Go make that directory, then run bitcoin. If a bunch of files show up in there, you've done it correctly.

  3. Yep.

    • -datadir
    • File > Backup Wallet
  4. Yes, but not GPU mining. GUI miner is a nice option though.

  • Did the same. Unless I did something wrong, it doesn't seem to work. – Chiffa Dec 2 '13 at 0:45
  • What is the full datadir syntax, windows returns the error of: "The name of C:\[Path To]\Bitcoin-qt.exe-datadir=E:\Bitcoin_Wallet specified in the Target box is not valid. Make sure the path and file name are correct"? – GiantCowFilms Oct 26 '14 at 16:58
  • 1
    @GiantCowFilms There's supposed to be a space between exe and -datadir. – Nick ODell Oct 26 '14 at 17:01
  • Fixied!(Thanks @NickODell) for any one who is curious, here is the full syntax:C:\Program Files (x86)\Bitcoin\bitcoin-qt.exe" -datadir=e:\Bitcoin_Wallet – GiantCowFilms Oct 26 '14 at 17:03

Just FYI, you can use Windows based solution, create reparse point that point to another directory, just like symlink in Linux

  • I don't have enough rep to down vote. See comments for Bitcoiner's answer. We established there is an accepted answer, this has nothing to do with Linux and complete sentences are appreciated. – Garrick Sep 4 '14 at 19:14

It seems several people are interested in how to create symbolic links in Windows. I know I was. This allows you to move your data directory to another hard drive without having to add the datadir flag.

It's actually not that much different.

To create a symbolic link (called a junction in Windows land) in Vista or later:

mklink /J <Link> <Target> 

Make sure the folder path that you use for the <Link> doesn't exist before creating.

(c:\<user>\AppData\Roaming\Bitcoin by default.)

Reference: Wikipedia

How do I move my Bitcoin Core data file

  1. Safely exit Bitcoin Core (bitcoin-qt|bitcoind).
  2. Make a new secure backup copy of your wallet.dat.
  3. Move you entire .bitcoin folder to the new location, except for bitcoin.conf which you must leave where it is in the existing .bitcoin folder.
  4. Edit bitcoin.conf to add datadir={full path to new .bitcoin folder}.
  5. Start Bitcoin Core and check properly that everything is alright, your wallet is accessible and, balances correct, etc.
  6. Protect your USB disk and make regular secure backup copies of your wallet.dat.

The alternative if you also move your bitcoin.conf file is to find and edit every shortcut that starts any Bitcoin Core process wherever they may be (and any new ones you make) and add the following including every time you type it at the command line -datadir={full path to new .bitcoin folder}.

Note: If storage space is an issue you can also enable the prune option; enter prune={number=>551} in your bitcoin.conf. The number is in MB.

That didn't quite work at first for me because some linux distros don't seem to like creating a symbolic link named “.bitcoin”.

I created a symbolic link named “test” in my home directory and then renamed that to “.bitcoin”

Using bitcoin-qt in Xubuntu12.04, this did not work:

ln -s /new/path/to/.bitcoin .bitcoin 

Did work:

  • exited bitcoin-qt
  • moved “.bitcoin” to another partition
  • created a valid symbolic link to there named “test”

    ln -s /new/path/to/.bitcoin test
    
  • renamed “test” to “.bitcoin”

  • 1
    Could you please add some formatting and elaborate what you are referring to with "that"? – Murch May 19 '14 at 21:02
  • 1
    It's not the distribution that prevents symlinks from working, usually it relates to the filesystem or the expectation of the bitcoin software that directories, paths and other URI data operates as expected. There are better solutions than symlinks, especially across multiple filesystem types. – Ben Jun 4 '14 at 10:01
  • Also, providing an answer for Linux when the OP clearly stated they were using Windows is pointless. – Ben Jun 4 '14 at 10:02
  • @Murch +1 That is constructive. – Garrick Sep 4 '14 at 19:08
  • 1
    @Ben To be fair, having received the answer I was looking for, I'm not opposed to someone adding "I had the same problem on [linux] and here is how I solved it". That will add future value to someone. Unfortunately these instructions are barely coherent and lamenting "the instructions for [Windows] didn't work on my [Commodore 64]", no kidding. – Garrick Sep 4 '14 at 19:09

protected by Community Jan 8 '17 at 22:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.