1

I have set up my bitcoin/lnd full node and would like to have it run as a routing node for the network. So I have opened my port 9735 from the router and allowed access to it in my firewall (ufw on Ubuntu).

enter image description here

Now, although my node is running and listening, my port still appears as closed. I have had no issue establishing connections or opening channels with other nodes but it seems they cannot connect to me.

Here are are my bitcoin.conf and lnd.conf file as well:

bitcoin.conf

# server=1 tells Bitcoin-Qt and bitcoind to accept JSON-RPC commands
server=1

listen=1
daemon=1

# RPC server options
rpcuser=xxxxxxxxxxxx
rpcpassword=xxxxxxxxxxxx

zmqpubrawblock=tcp://127.0.0.1:28332
zmqpubrawtx=tcp://127.0.0.1:28333

# Connection options
bind=192.168.0.12
externalip=94.107.123.223

# Use only TOR for routing
proxy=127.0.0.1:9050
bind=127.0.0.1
externalip=f5arugxcfm4tkjtc.onion

# Long running Bitcoin Nodes on the Tor Network
# http://nodes.bitcoin.st/tor/
addnode=pqosrh6wfaucet32.onion
addnode=btc4xysqsf3mmab4.onion
addnode=gb5ypqt63du3wfhn.onion
addnode=3lxko7l4245bxhex.onion

# Verified Online Bitcoin nodes on the Tor Network from 
# https://rossbennetts.com/2015/04/running-bitcoind-via-tor/
addnode=kjy2eqzk4zwi5zd3.onion
addnode=it2pj4f7657g3rhi.onion

# Verified Online Bitcoin nodes on the Tor Network from 
# https://en.bitcoin.it/wiki/Fallback_Nodes#Tor_nodes
addnode=hhiv5pnxenvbf4am.onion
addnode=bpdlwholl7rnkrkw.onion
addnode=vso3r6cmjoomhhgg.onion
addnode=kjy2eqzk4zwi5zd3.onion

# Verified Online Bitcoin nodes on the Tor Network from 
# https://sky-ip.org
addnode=h2vlpudzphzqxutd.onion
addnode=xyp7oeeoptq7jllb.onion

# Maintain a full index of historical transaction IDs
# Required by LND Server
txindex=1

lnd.conf

; set external IP if not using NAT
externalip=94.107.123.223
; set node alias (seen in explorers)
alias=ln.brussels

tlsextraip=192.168.0.12
rpclisten=0.0.0.0:10009
restlisten=0.0.0.0:8080
listen=0.0.0.0:9735

[Bitcoin]
bitcoin.active=1
bitcoin.mainnet=1
bitcoin.node=bitcoind

[Bitcoind]
bitcoind.rpcuser=xxxxxxxxxx
bitcoind.rpcpass=xxxxxxxxxx
bitcoind.zmqpubrawblock=tcp://127.0.0.1:28332
bitcoind.zmqpubrawtx=tcp://127.0.0.1:28333
  • 2 questions: 1.) is your machine behind a router that has no portforwarding? Second: ufw shows tcp6 have you tried to allow port 9735 specifically for ipv4 which is the address you seem to check? – Rene Pickhardt Jan 9 at 19:52
  • Let me respond to the second one first, as far as I know ufw allows both ipv4 and ipv6. The command ufw status shows 9735 both with and without (v6). As for the first question, I'm not quite sure, I am using a devolo wifi extender so that could be the issue. However, I believe there are no settings for port forwarding. Does that mean the only solution is to connect the node directly to my modem? – Stelios Rammos Jan 9 at 20:47
  • May I add, using the same website to check the open port (yougetsignal.com/tools/open-ports), the bitcoin node port 8333 shows open. However, bitnodes shows the node as unreachable. Appreciate your help! – Stelios Rammos Jan 9 at 20:55
  • I cannot comment on your hardware. But there might be a general hint. If you are behind a firewall you can run a lightning node on a tour onion. Since your node connects to the tor network and people over the onion connect to you you don't need any open ports. – Rene Pickhardt Jan 9 at 22:49
  • Nice, I hadn't thought about that! To be honest, I would really like to grow the node into a routing node for the whole network and with my understanding of tor that wouldn't be the case. I'm really at a dead end here though so my options seems fairly limited. The ISP also assures me it's not blocking the port... – Stelios Rammos Jan 9 at 23:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.