0

Continuing on from this post: Configure esplora to point to the bitcoind servers ip address - Part 2

Trying to run cargo run --release --bin electrs -- -vvv --daemon-dir ~/.bitcoin, but it kept saying - reconnecting to bitcoind: no reply from daemon.

The bitcoin.conf file has a rpcuser and rpcpassword set. I have set the same username:password in in that format for the .cookie file for electrs.

Any idea why it's not connecting?


EDIT:

More details below:

enter image description here

I then create .cookie file in that location with the rpc username:password and then get this message: "no reply from daemon"

enter image description here

1
+50

Have you checked the following:

  • do you use bitcoin rpc standard port for the network you are using? If not or not sure specify it explicitly with --daemon-rpc-addr 127.0.0.1:8332

  • Are you sure the .cookie file is in the default position? Try the explicit option --cookie username:password

  • Is bitcoind on the same machine? By default only rpc connection from localhost are allowed

If none of the above work, please post log from eletrs

| improve this answer | |
  • How do I access the electrs logs? – oshirowanen Apr 2 at 16:56
  • copy and paste stdout – Riccardo Casatta Apr 3 at 6:57
  • Further details added. – oshirowanen Apr 11 at 15:21
  • 1
    so I imagine /mnt/shared/.cookie file contains your rpcuser and rpcpassword, not sure what's happening, did you try to launch electrs with the explicit --cookie RPCUSER:RPCPASSWORD option? – Riccardo Casatta Apr 13 at 8:04
  • --cookie RPCUSER:RPCPASSWORD worked, but it doesn't work in the .cookie file. Thanks for the help. Now I have another error. Will create a new post for that. – oshirowanen Apr 15 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.