1

Does anyone know why I can't dump info into a text file?

It also doesn't allow me to back up my wallet.

i am using SNAPenter image description here

1
  • Try giving an absolute path. Apr 21 '20 at 17:52
1

If you installed Bitcoin Core via Snap, then you can easily dump your wallet keys to snap/bitcoin-core/common/ directory, like

dumpwallet /home/alex/snap/bitcoin-core/common/walletdump.txt

In case of success, you'll see the following response:

{
  "filename": "/home/alex/snap/bitcoin-core/common/walletdump.txt"
}
1

To fix this on Windows I had to specify the full path to a folder, and it could not be inside Program Files. This full path worked

C:\Users\me\Desktop\temp\test
0

Last time it happened to me, it was because the user of bitcoind didn't have the write permission in the dir I tried to dump the backup.
I think you should check the permission for the bitcoin directory, or try to change the path where to dump your wallet backup and see if it still fails.

4
  • I try to make the backup in my home but it doesn't allow me Apr 21 '20 at 15:48
  • which user "home" is it? The one that is running bitcoind or the one you are calling the rpc method right now? Where is the bitcoin directory and what is its permission? Can you make other rpc call?
    – Sosthène
    Apr 21 '20 at 16:11
  • The one that is running bitcoind and the one is calling the rpc method are the same user. BTC directory is ~/snap/bitcoin-core/common/.bitcoin with permission 775. But I am trying to backup in /snap/bin with permission 777 Apr 21 '20 at 16:30
  • Ok it's probably not the problem I was thinking about then, sorry for the false hope!
    – Sosthène
    Apr 21 '20 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.