I have a funding transaction stuck in mempool due to low fees. Searchng around I have find that there is "BumpFee" wallet option to push your transaction. i have tried in this way:

~$ lncli wallet bumpfee [Channel_point] --sat_per_byte 150

>[lncli] rpc error: code = Unknown desc = the passed output doesn't belong to the wallet

When type:

~ $ lncli pendingchannels

i can see the transaction waiting for confirmation, but when type:

~$ lncli wallet pendingsweeps

{ "pending_sweeps": [] }

there arent. The transaction is still present when type:

~ $ lncli listchaintxns

Someone can try to explain or have had similar behaviour? Don’t found so much useful stuff in Github


2 Answers 2


I solved the problem whit CPFP (children pay for parent).

I used the unconfirmed change of the fund TX stuck in mempool to open a new channel.

At the time of broadcasting TX the median fee is around 150sat/vb, so i chose to slight increase at 200 sat to ensure good probability to push the first fund tx and the second one in the next block avaible.

  • 2
    Can you please give me the command using the fund TX stuck in mempool to open a new channel? When I do a new 'lncli openchannel' I cannot specify the fund TX stuck in mempool. I tried it with the same Public Key and the same local-amt but instead a new channel was opened to this Node. The old unconfirmed transaction still stuck on the mempool. Again: Can you please post how the command TX stuck in mempool to open a new channel looks like? Thanks in advance Jul 18, 2020 at 11:49

I got a sweep TX (from a force closed channel) stuck, also due to low fees. This answer is inspired by OPs answer.

I got it working with:

lncli openchannel \
--sat_per_byte=${fees per byte for the funding transaction of the new channel} \
--min_confs=0 \
${remote nodes id} \
${local amount}

The --min_confs=0 part is the important bit, it allows lnd to use unconfirmed TXes for the funding, but that doesn't mean it will use that particular unconfirmed TX.

bos seems to have an option for specifying UTXOs with their bos fund --utxo ${utxo} command. (haven't tested that)

bos fund can be used with other commands for example bos open to open (multiple) channels as described here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.