0

So I just unboxed my Nano X direct from Ledger. I started the device and it said download Ledger Live.

So it set it down to go look for my phone. The thing was, I had trouble finding my phone and by the time I did that, the Nano screen seemed to be in some kind of screen saver mode. Still, I downloaded Ledger Live onto my iPhone and turned back to work with the Nano.

However, it seems to be stuck on a menu with 3 options: Close/Exit control center, Battery, Power Off.

The left and right buttons will take me through those three items all day long.

I expected pressing the left and right buttons together would take me someplace useful, but not so. I have held the left and right button together for up to 60 seconds . . . nothing. I have even held both button while looking at each of the three menu items thinking one of them night work. No so. To my surprise, holding both buttons while looking at power off doesn't power off the device either.

I never got far enough to set a pin yet, so it isn't asking for one so I cannot enter it three times wrong.

Suggestions?

==== Next Day ====

The next day it seems like the Nano X had started over. I ran through all of the startup messages and eventually got to the point it asked if I wanted to setup as new device. However, when I press and hold both buttons, instead of asking for a PIN it goes to the 3 options mentioned above: Close/Power Off/Battery.

I've done this a couple of times now . . . the device has yet to ask me for a PIN or try to give me restore words . . . I have no idea what to try next except returning it to Ledger.

Frank

1

When pressing both buttons, it appears there is some kind of "long click" that does different things than a quick press of both buttons. Not knowing that I was consistently doing long click which confused the Nano X. Once I figured out that a quick tap of both buttons was all that was needed to select an item, thing started getting more sane.

Having done a long click once at the very beginning, put me into that special menu mentioned above and once I was there I was lost. However, I let the device timeout and go to sleep, then using quick/short double presses only, everything worked as per documentation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.