1

I'm trying to import a multisig wallet on regtest, but getting a strange error. What am I doing wrong? I've tried it with xpubs, tpubs, and Vpubs (converted here) and get the same error for all.

Command:

bitcoin-cli -regtest importmulti '[{"desc": "wsh(multi(2,tpubDDgGUQsV9M7N5DD3WQmkqkq9UXkSvfHvyefNDx2b7KwmukE6FfuFk3JfncmjCNnG9scWcdz6MEeNPZXHArkGFuTXTsZNr4288ULxuTDjB6u/0/0/*,tpubDCDw2UcGohVP3rK8kPW8g9hwBojpwzYdjLxQ6AnnuRvThH7q1vwGneGAUkfZYqJo9eKFGzuP4WwaKsQkEqqnwLd1eT2CtpAKQispgxadHWB/0/0/*))", "range": [0,10], "watchonly":true, "timestamp":"now"}]'

Error:

[
  {
    "success": false,
    "error": {
      "code": -5,
      "message": "Missing checksum"
    }
  }
]
0

According to the documentation, some RPCs need a checksum. importmulti is one of those.

You can use getdescriptorinfo to add a checksum to an existing checksum-less one.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.