I'm trying to setup a bitcoin lightning node on my NAS (Synology), following this tutorial: https://bitcoindev.network/running-a-lightning-node-on-synology-nas/

Unfortunately I get the following error (log):

lightningd: WARNING: default network changing in 2020: please set network=testnet in config!
Could not connect to bitcoind using bitcoin-cli. Is bitcoind running?
Make sure you have bitcoind running and that bitcoin-cli is able to connect to bitcoind.

You can verify that your Bitcoin Core installation is ready for use by running:
        $ bitcoin-cli -testnet echo 'hello world'   

2020-06-30T19:45:20.256Z INFO plugin-bcli: Killing plugin: Plugin exited before completing handshake.
The Bitcoin backend died.
lightningd: WARNING: default network changing in 2020: please set network=testnet in config!

My lightning.conf contains the following:


I've tried several parameters for bitcoin-rpcconnect (internal ip, external ip of my bitcoin node including the right ports).

Since my bitcoin node is running on mainnet I try to setup the lightning node for mainnet as well.

So does anyone knows what I'm doing wrong?

  • It seems that lightningd isn't using the mainnet (notice the -testnet in the bitcoin-cli line), are you sure the config is in the correct place? Notice that you call the file lightning.conf but it should really just be config in the correct directory.
    – cdecker
    Jul 1 '20 at 9:07
  • I tried to name the file just config but unfortunately it gives the same error. So any ideas what else it might be?
    – WaZZa
    Jul 1 '20 at 16:34
  • You can always pass any options you have specified in the config on the command line, alias=myalias just becomes --alias=myalias and so forth. That eliminates at least the config filename source for issues.
    – cdecker
    Jul 2 '20 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.