2

I have everything set up normally. My only issue is that my data directory is in C:\Users\User Name\AppData\Roaming\Bitcoin.

Normaly this is what you would want, but, if you noticed, my username has a space in it (obviously I changed it for privacy) so when I try to designate my data directory in the miner program it says the directory does not exist because the space in my username causes the directory link to break ( C:\Users\User ) instead of the full link...

Is there a way I can change where Bitcoin-Qt stores its data by default?

And no, a re-directory won't work, because it can't find the location in the first place.

3

Run bitcoin with the parameter -datadir=C:\New\Dir

E.g. create a shortcut and change "target" to "C:\Program Files (x86)\Bitcoin\bitcoin-qt.exe" -datadir=C:\BitcoinData

  • where do i go to add the parameter? – DragonspitAudio Apr 13 '13 at 8:54
  • ok i created a shortcut for bitcoin-qt and i added -datadir=C:\BitcoinData to the end but it just says C:\BitcoinData doesnt exist – DragonspitAudio Apr 13 '13 at 8:59
  • issue solved, i changed my Username via another admin account and regedit to change the log in defaults – DragonspitAudio Apr 13 '13 at 12:01
  • -datadirC:\BitcoinData as strange as it is, do not put no nothing between datadir and your dir..... – n611x007 Jul 14 '13 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.