1

I have the Bitcoin Client running on my laptop, it is up to date and now fully synchronised, but it is running the CPU at almost 100% and so makes doing anything else extremely slow. Is this normal?

Whilst it was 'synchronising with the network' it was doing the same but I assumed it was because synchronising with the network used up a lot of processing power, but it does the same now - is this likely to always be same or have I done something wrong in the set up? (my laptop has 2GB memory, has 2.20GHz processor and running on windows vista)

Many thanks in advance

  • Are you sure that it's the bitcoin client? Can you post your debug.log? – Nick ODell Apr 16 '13 at 17:17
2

The normal bitcoin client should not use more than a few percentages, if not even zero, from your CPU.

What client are you running? The Bitcoin-Qt client? Did you ever enabled the "generate bitcoins" option? I'm not sure if it's in the Bitcoin-Qt client's settings, but you could've enabled it in your bitcoin.conf file.

Maybe you should post your bitcoin.conf file. Or just make sure it doesn't have generate=true in it.

1

For the initial synchronization with the Bitcoin network, you may see elevated CPU and disk usage. During this synchronization process, the client downloads from other nodes in the network each block. The client verifies each block itself.

Given that you're running Vista, your computer is probably at least five years old. Its performance may be impacted more than more modern computers.

You may want to consider using the boostrap.dat method of synchronizing more quickly and with less performance impact. This method will synchronize the first ~216k blocks much more quickly. Once imported, your client will resume normal synchronization. Please ensure that you are using Bitcoin-Qt 0.8.0 or newer in order to avoid problems with this method.

0

I had the same issue on Win8 with Bitcoin Client v0.8.5-beta, and was able to solve it by turning off "gen", but there was no bitcoin.conf file on my system and had to create it manually myself at the following location:

D:\Users[user name]\AppData\Roaming\Bitcoin\bitcoin.conf

Inside the file simply include:

gen=0

Once you save it, restart the bitcoin client, and if you have the same experience I did, you will notice cpu go down to near 0, even during sync.

For a list of bitcoin.conf locations on Mac and Linux refer to:

https://en.bitcoin.it/wiki/Data_directory

For a full list of all conf options refer to:

https://en.bitcoin.it/wiki/Running_Bitcoin (under heading "Sample Bitcoin.conf")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.