1

On Debian I successfully compiled .bitcoind without a wallet, but now I need the wallet.

./configure tells me I need Berkeley CXX headers. Searching for how to do this on Debian brings up a bunch of Ubuntu answers saying to do either

sudo apt-get install libdb4.8-dev libdb4.8++ libdb4.8++-dev

after having added a PPA, or

wget http://download.oracle.com/berkeley-db/db-4.8.30.zip
unzip db-4.8.30.zip
cd db-4.8.30
cd build_unix/
../dist/configure --prefix=/usr/local --enable-cxx
make
make install

Both solutions throw errors. I'm focusing on the 1st solution.

The first solution throws this error:

The following packages have unmet dependencies:
 libdb4.8++ : Depends: libgcc-s1 (>= 3.0) but it is not installable

I'm not sure, but I assume this may be an Ubuntu vs. Debian issue? How can I bypass it?

2

You probably need a newer version of gcc.

This helped me fix for Ubuntu: https://askubuntu.com/questions/1140183/install-gcc-9-on-ubuntu-18-04

TL&DR: adds custom PPA repo so you will able to upgrade:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt update
sudo apt --fix-broken install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.