When I try to send regtest Bitcoin using bitcoin-cli:

./bitcoin-cli -regtest sendtoaddress bc1q09vm5lfy0j5reeulh4x5752q25uqqvz34hufdl 0.1

I get the error message:

error code: -6
error message:
Fee estimation failed. Fallbackfee is disabled. Wait a few blocks or enable -fallbackfee.

How do I resolve this so I can send regtest Bitcoin?


You could enable -fallbackfee as it says in the error message but the easiest or quickest way to resolve this is to set a fee. In this example we are setting a fee of 1 satoshis per byte.

./bitcoin-cli sendtoaddress "bc1q09vm5lfy0j5reeulh4x5752q25uqqvz34hufdl" 0.1 "" "" false true 1 sat/B

If you do

./bitcoin-cli -regtest help sendtoaddress

you will see what those arguments after the regtest address represent.

Alternatively if you want to set the fallback fee see this StackExchange question.

This PR 16524 merged in October 2019 disabled -fallbackfee across all chains (mainnet, testnet, regtest) by default.

Not the answer you're looking for? Browse other questions tagged or ask your own question.