2

I tried to upgrade bitcoin core from 0.18.0 to 0.20.0.

When I ask for the version through bitcoind bitcoind --version it prints Bitcoin Core version v0.20.0 but if I ask for the version through bitcoin-cli bitcoin-cli getnetworkinfo it prints "subversion": "/Satoshi:0.18.0/"

How is this possible that this is not the same?

3
  • bitcoind --version is asking the bitcoind binary what its version is
  • bitcoin-cli getnetworkinfo asks the currently running bitcoind what its version is

So this means that you at some point had a 0.18.0 bitcoind, started it, then installed a 0.20.0 one, but the 0.18.0 one is still running.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.