As of May 31, 2023, we have updated our Code of Conduct.

Questions tagged [make]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers

Openssl errors when building the bitcoin-core on macOS

I have been trying to build bitcoin-core on macOS as I am reading the "Mastering Bitcoin" book from Andreas Antonopoulos. I read the instructions for building the the bitcoin-core on macOS ...
Alex  Matei's user avatar
0 votes
0 answers

unable to install bitcoind (macOS, M1 chip)

I've been trying to install bitcoind on a new mac (Big Sur 11.4). I followed the instructions in doc/ and installed all required dependencies, but when I try to run make, it gives me the ...
distracted_coder's user avatar
2 votes
1 answer

How do I compile Bitcoin Core to be more portable?

Background: I compile bitcoind on one system but run it on another. When I compiled bitcoind 0.19.1 some time back using the following method, I was able to run bitcoind and bitcoin-cli on the target ...
Mike's user avatar
  • 454
1 vote
0 answers

Bitcoin Core make

Whenever I try to recompile my changed files in Bitcoin core. I have to run make clean and then make or else it wont compile the changed files. It just goes back to the last compiled file. How do i do ...
Sishir Giri's user avatar
0 votes
0 answers

BitcoinCore Ubuntu buiild error: ‘relative’ is not a member of ‘fs’

I'm trying to build Bitcoin core client on an LinuxMint. I'm having the following error(which have not encountered before, while making it on MSWindows or another Linux machine) in make process, right ...
behkod's user avatar
  • 303
0 votes
1 answer

bitcoin compile (.undefined reference to **')

I'm getting error after make command like, undefined reference to `BlockAssembler::BlockAssembler(CChainParams const&)' and in last Makefile:774: recipe for target 'all-recursive' failed make:...
levi's user avatar
  • 3
0 votes
1 answer

How many unit test should be run after building a node?

After building Bitcoin ABC and running make check, I get this: # TOTAL: 1 # PASS: 1 # SKIP: 0 # XFAIL: 0 # FAIL: 0 # XPASS: 0 # ERROR: 0 Is that correct?
Curyous's user avatar
  • 131
2 votes
2 answers

Issue on configuring the bitcoin core build on Ubuntu-18.0.4

I am trying to configure the bitcoin core build , as I use make , I received the following issue . ~/Desktop/bitcoin$ make Making all in src make[1]: Entering directory '/home/fu/Desktop/bitcoin/src'...
Fu Liang's user avatar
1 vote
0 answers

Adding libraries to [closed]

I am trying to add already existing library below to dash source code : Jerasure I have included all the source and header files in a directory 'jerasure' inside 'src'. In the , I have ...
thenakulchawla's user avatar
0 votes
1 answer

Internet of Money git download error

I tried to download the pdf from the following repository but i get an error Ive done the following: $ git clone $ cd ...
2313112441312's user avatar
1 vote
1 answer

modifying bitcoind to include mysql support

I am modifying bitcoind (working with 0.13.1) to include write the log to mysql db versus the log file. I have all the functions worked out and compiling outside of bitcoind The trouble I ran ...
Albert s's user avatar
  • 1,590
0 votes
1 answer

Compiling an ALTCOIN on Ubuntu, getting errors during make

Hi I am compiling an ALTCOIN forked from another coin, I'm using Ubuntu Server 16.04 LTS via SSH from a remotely hosted server. I believe I installed all dependencies because I have already compiled ...
user54097's user avatar
1 vote
0 answers

make: *** No rule to make target 'all'. Stop. Stellar-core [closed]

I followed the instructions on how to install the stellar core but when I ran make install, I got this error: make: *** No rule to make target 'all'. Stop. I configured it and everything worked ...
Hugh Heimler's user avatar
2 votes
0 answers

Cannot build secp256k1 C library on Debian stretch

I was hoping that someone would be able to suggest something about this (the same process works perfectly fine on my Debian Jessy machine) $ uname -a Linux front 4.8.0-1-amd64 #1 SMP Debian 4.8.7-1 (...
Sven Williamson's user avatar
1 vote
0 answers

Failing to build bitcoin-core v0.13.1

I have done quite a few upgrades in the past and this has never happened before: $ uname -a Linux back 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u1 (2016-09-03) x86_64 GNU/Linux $ git checkout v0....
Sven Williamson's user avatar
6 votes
1 answer

Building on Ubuntu 16, missing SSL during ./configure

I am trying to build bitcoind on Ubuntu 16 64-bit. I have installed the dependencies and have built it fine many times on other machines. During ./configure, I am getting checking whether the Boost::...
Matthew Darnell's user avatar