Hot answers tagged

13

Your private node would still be a fully validating node (i.e. full node). That's a good thing. As for having the private node connect to your public node, you have two choices: -addnode=<ip> Add a node to connect to and attempt to keep the connection open -connect=<ip> Connect only to the specified node(s) What you were asking for is nr 2, ...


6

If you don't want to, you don't have to open ports at all. You'll still have a full node, it will just have fewer connections. Full nodes usually make 8 outgoing connections and can have many more incoming if you have the port open (for a total of 125 by default). Incoming connections can also be SPV (phone) wallets, or other full nodes. So the benefit is ...


6

When your node is not accepting inbound connections (either because there's NAT in the way or because you passed -listen=0 to Bitcoin) it still makes "outbound connections." These are connections to other Bitcoin nodes that are listening on a public port. Your node makes a maximum of 8 outbound connections. (Source.) When you make an outbound connection, ...


5

I had the same problem. The port was open, but the test at bitnodes.21.co would fail. However after my Bitcoin client downloaded the entire BlockChain everything worked. I used about 144 hours to download the entire chain with a 150Mbps fiber line. Before the entire chain was downloaded the test at https://bitnodes.21.co/#join-the-network would give an "...


5

There are several Bitcoin Clojure projects, but none of them appear to have a full rewrite of Bitcoin as a goal. Of particular interest is https://github.com/johnwalker/bitcoin-protocol , which is an implementation of the Bitcoin networking protocol. It can be used to communicate with peers within Bitcoin networks. Rewriting Bitcoin core in another ...


3

Found the solution: rpcport needs to be in the [test] section Please update your original config file to read: testnet=1 server=1 daemon=1 txindex=1 rpcuser=XXXXXXXXXXXXXXXXXXXXXXX rpcpassword=XXXXXXXXXXXXXXXXXXX rpcallowip=127.0.0.1 onlynet=ipv4 zmqpubrawblock=tcp://127.0.0.1:28332 zmqpubrawtx=tcp://127.0.0.1:28333 [test] rpcport=19832 And restart the ...


3

External host is the IP of the host connecting to you. If you want to allow anyone to connect, you can just put 0.0.0.0.


3

Having multiple nodes running will help you get connected to more peers. The algorithm behind finding peers takes into consideration a variety of variables, such as the success rate of previous connections, and the IP addresses that get relayed by other nodes. Therefore, the more nodes you have running, the better the chances of connecting to different peers....


3

I've had to do this, so I'll try to describe exactly what you need to do to get mining on testnet to work in a local setup. For our purposes, we'll have 2 instances of bitcoind running, the first set up to be a miner, the second as a peer. First, create two directories, one for the miner, the other for the peer: $ mkdir 1 $ mkdir 2 Now create this file in ...


2

Port 8333 is only relevant for inbound connections. Opening it allows other nodes to start talking with your node. That said, a Bitcoin node can fully participate in the network even if you don't allow inbound connections (to port 8333). It'll use outgoing connections, which start from random higher unprivileged ports and connect to port 8333 of another node....


2

You are conflating the two ports that Bitcoin Core opens and uses. There is the Bitcoin network port. That is port 8333 by default. You DO NOT want to try to connect to that as it is used for the connection to other nodes on the network. The port that you do care about is the rpcport. That is port 8332 by default. This is the port that you want to connect ...


2

Bitcoin Core doesn't seem to have an option to specify the source port for outgoing connections, so you probably can't assume anything about the source port. However, if possible, you could configure your router to look for outgoing connections with destination port 8333, which will probably be the port used by most peers.


2

In the Type dropdown menu, change HTTP to All TCP; enter 8332 as the port number; enter the IP of the computer that will be sending RPC requests under 'Source.'


1

First, check your router opens that port too and redirects that port to you computer. Then check CGNAT. If the external IP address your router shows isn't the same as you find when you search for "what is my ip", your ISP is giving the same IP to multiple customers. So you won't be able to open a port.


1

Yes you can and the node will still sync and push transaction data. Most of the nodes are behind NAT and not reachable anyway from the internet. These nodes are initiating connection against random nodes and then the communication become bidirectional, allowing to receive blocks. Nodes that are exposed to the internet are important, to bootstrap nodes ...


1

so, I checked my router whether the port number(48302, 44660) is opened or not but, no any port is currently open. They don't appear open because those ports are not always open listening for incoming connections. Rather those ports are bound to temporarily by the forwarding software which then initiates the connection to your computer. As soon as the ...


1

Nodes that participate in the Bitcoin network run a computer program such as this one: https://github.com/bitcoin/bitcoin, which dictates how everything works. To answer your more specific questions: Yes, bitcoin once used UPnP, here are some more details: https://dirkmittler.homeip.net/blog/archives/3340 but in modern versions it does not (thanks for ...


1

It looks like a bug: I've also replicated the same behaviour on my machine using the current version, Bitcoin Core Daemon version v0.17.99.0-g2945492424934fa360f86b116184ee8e34f19d0a freshly downloaded from github. However I notice @Зелёный above was unable to replicate it, so perhaps the bug is in a library you and I share and he doesn't, rather than in ...


1

I had the same problem after following all of the usual steps. I waited and it still didn't work. I had to change my computer's firewall (in the Inbound Rules) for the Bitcoin Core (highlighted one below) to have a Private Profile. It was "Private, Public" at first. You can see if you have both directions working from this icon. Both parts of the U's to ...


1

I would guess addrlocal shows you your endpoint of the connection, that is your IP address and port number. For all incoming connections that would be the same as the IP address and port you are listening on, so that's why it's not displayed. In your case most likely: 137.122.81.217:8333 I'm not sure what would happen if the server is multihomed.


Only top voted, non community-wiki answers of a minimum length are eligible