Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now

New answers tagged

1

It seems like pkg-config found libsecp256k1 in the build-libbitcoin directory. which is part of libbitcoin, so they probably build libsecp25k61 there. The reason your code doesn't compile is because your libsecp was compiled with libgmp enabled, now this is a dynamic link. So if you're trying to create a binary here you need to add -lgmp and if it's not in ...


0

I could solve the issue by using the --static attribute: g++ -o addr 69_addr2.cpp $(pkg-config --cflags --libs --static libbitcoin)


Top 50 recent answers are included