2

My bitcoind started synchronising blocks. The bitcoind version is 0.93. When the bitcoind found an orphan blocks in the synchronising process, it seems stop and did not work. the message from the log like this:2015-01-08 06:08:19 ProcessBlock: ORPHAN BLOCK 184, prev=0000000000000002d79cd7069cedd05f49716354590bd5518b18a513b3b4d513

I need restart it and it would continue synchronising. This case happens many times. sometimes the bitcoind found orphan blocks in the synchronising process, it would continue work. I don't where is wrong. Any ideas? Big thanks.

note: my system is CentOS

  • please, tag the OS you are using: linux, windows, etc – Xawery Wiśniowiecki Jan 8 '15 at 11:16
1

The new version (0.10 / RC1) has a rewritten block-download mechanism which significantly improves synchronization which could result in less similar issues.

A workaround for the current version is to deploy the -maxconnections=<n> option and set it to a low number to reduce parallelism and thus receive less orphans in total. Set -maxconnections=1 to receive little to no orphans (essentially only for the newly announced blocks).

You can also use the -maxorphanblocks=<n> option (which has a default value of 750), try decreasing it and the daemon will probably bypass the stall point, as keeping less max orphans will prevent your system from running out of resources (eg RAM), which I suppose is what currently happens.

Another workaround is to just download the bootstrap.dat torrent if you are still many weeks behind the current block.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.