2

I am using insight-api for get block chain information. When i am trying to start insight i am getting error "ERROR code=-28, message=Activating best chain..." . I saw this error first time,please help me how to reslove this.

Full stack trace of error:

                v0.2.12

connection info: insight server listening on port 3000 in development mode

error: ERROR code=-28, message=Activating best chain...

I am unable to understand error. i am using insight-api for this.

Thanks in advance

3

Your node is still starting up, you need to wait until it is finished before using the RPC interface. The RPC message is telling you to call back later, which insight-api doesn't seem to be able to understand, simply waiting until the node is completely active is a suitable workaround. This may take a few minutes depending on your servers hardware, the bitcoin-cli tool supports automatically waiting for the interface to be available with the -rpcwait flag.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.