1

Was there a recent change where it is no longer possible to specify rpcport?

I noticed these two warnings: Warning: Config setting for -addnode only applied on test network when in [test] section. Warning: Config setting for -rpcport only applied on test network when in [test] section.

After trying adding a [test] section I got very mixed results as some times it disregarded all options and in general rpcport was still not set.

I could not find any documentation on how to do this.

2

For any of addnode, connect, port, bind, rpcport, rpcbind, and wallet you should move them into the [test] and/or [main] sections of your bitcoin.conf. You can also move any other setting that you want only applied to mainnet or testnet into the appropriate section.

Example:

server=1
daemon=1

[main]
prune=1000

[test]
rpcport=55555

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.