1

I tried to sign a transaction and then broadcast it, but I get the following error:

Error! Failed to broadcast transaction: ecBlockHeight 221000 does not match ecBlockId 932...., transaction was generated on a fork.

What could be the cause of this?

If i sign the transaction and broadcast it manually via the ardor desktop gui wallet via "broadcast", it works. I'm just not sure how this error is occurring or what does it mean?

enter image description here

1

I got this same exact error when I tried to sign a mainnet transaction using a testnet API, so, make sure you are using the same network..

0

This is what we call a replay protection error, the ecBlockId and ecBlockHeight params must point to an existing block already in the blockchain. You can also omit these fields and let your node assign them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.