0

I‘m trying to do a liquid pegin. Generated the pegin address and sent funds to it, waited < 102 blocks. When trying to claim them with

liquid-cli claimpegin “rawtransaction“ “txoutproof“

The result is

    Error code: -8 
Error message: The txoutproof must contain bitcoinTx and only bitcoinTX

The txoutproof looks longer than in the example of bitcoin-cli help page and was done on a -txindex enabled full node gettxoutproof “[\“txid\“]“

00008020f2e6bcdb...

I‘m thankful for any clues what could be wrong. Am I doing something wrong with the claimpegin input parameter format?

Thanks in advance and kind regards.

  • This is really a service question. – Anonymous May 12 at 14:19
  • The proof length is variable in size based on the number of transactions in the block it is a proof for, so that isn’t unusual. – Anonymous May 12 at 14:22
  • The raw transaction and txoutproof didn‘t match due to a copy/paste error. – Philipp May 21 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.