0

I've been having a really hard time struggling through installation. The problem is there seem to be two ways to install, one through a download link and one through src. However, both methods still have many problems and the dependencies are unclear. I explained the specifics of the problem on GitHub.

I was hoping that I would be able to download bitcoin from GitHub, enter the src file, and run ./bitcoind or ./bitcoin-qt -server to be able to run in prune mode. However, I am still getting errors. For example,

IN:

./bitcoin-qt -server

OUT:

zsh: killed     ./bitcoin-qt -server

I am not able to download the whole blockchain at 500 GB, but I need to use the bitcoin-cli. My thought was running ./bitcoin-qt -server would allow me to prune the download as explained on StackExchange and operate bitcoin-cli, without having to run bitcoind first.

Questions

  1. Is running bitcoind necessary to run bitcoin-cli?
  2. Is it possible to run bitcoin-cli without downloading the entire blockchain?
  3. What is the cleanest path to getting started with bitcoin-cli on macOS?

1 Answer 1

2

Is running bitcoind necessary to run bitcoin-cli?

No, you can use bitcoin-cli with bitcoin-qt but you must first tell bitcoin-qt to listen for requests from blitcoin-cli - it does not do this by default.

$ ./bitcoin-qt -server &

See https://livebook.manning.com/book/grokking-bitcoin/a-using-bitcoin-cli/v-6/34


zsh: killed     ./bitcoin-qt -server

You probably need to reinstall homebrew.

See https://stackoverflow.com/questions/66119081/why-does-zsh-kills-my-process-every-time-i-enter-a-git-command

1
  • Thanks for the feedback. I think your proposed solution moves things in the right direction, but unfortunately the problem persists. I am no getting new error readout.
    – BSH180_44
    Jan 6, 2023 at 2:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.